Resolve Support Code 1890 - PIXMA MG Series Printers

Article ID: ART143381 | Date published: 05/13/2015 | Date last updated: 02/19/2020
 

Description

Understand and resolve Support Code 1890 on your PIXMA MG5520, MG5522, MG5620 or MG6420 printer.

Solution

Cause

The protective material or the tape may still be attached to the print head holder.



Action

Open the operation panel and make sure the protective material has been removed. Then close the operation panel.

Image shows protective material attached to print head holder



If the error remains after removing the protective material, the printer will require service or replacement.

There are two options currently available to you.

  1. Warranty Service – If you are within the 1-year manufacturer’s warranty and have your proof of purchase you are entitled to service or replacement. If you have purchased a CarePak Canon extended warranty, you may be entitled to additional options.  Please create or log into your Canon Account to obtain service.
     
  2. Out of Warranty – If you are outside of your warranty period, you may qualify for purchasing a replacement through the Canon Upgrade Program. Please contact our Sales group to inquire about your upgrade options at 866-443-8002.
     
To verify your support options please create or log into your Canon Account.


Rate this Article
Was this article helpful?
Yes, This document is helpful
No, This document needs a clearer explanation
 
Please provide your comments