Self-Registration Error installing MultiPASS Suite 4.30 on Windows 2000 (F20)

Article ID: ART125490 | Date published: 05/12/2015 | Date last updated: 08/14/2015
 

Description

Self-Registration Error installing MultiPASS Suite 4.30 on Windows 2000 (F20)

Solution

Self-Registration Error installing MultiPASS Suite 4.30 on Windows 2000 (F20)

Self-Registration Error installing MultiPASS Suite 4.30 on Windows 2000 (F20)

While installing MultiPASS Suite 4.30 or running the MultiPASS Repair program on a Windows 2000 computer, the following message may appear.

Message:
"Self-Registration Error
The following files did not self-register or unregister:
1. C:\Program Files\Canon\MultiPASS\DTM4.DLL
An event was unable to invoke any of the subscribers
To continue, click OK: otherwise click Cancel."

Clicking 'OK' to the above message will continue the installation and then display the below message. Clicking 'Cancel' will exit setup and return the user to the MultiPASS Setup splash screen.

Message:
"Severe
Your MultiPASS registry may be broken.
Please run Add-Remove Programs and Repair the MultiPASS installation."


Cause:
Registry key HKEY_LOCAL_MACHINE/SOFTWARE/CANON does not have Full Control permission in regedt32.

Solution:
Open regedt32, select HKEY_LOCAL_MACHINE/SOFTWARE/CANON/ folder, apply Full Control to the Canon folder and reset permissions. If the software was already installed (clicking OK at the Self-Registration Error message), run Repair from Add/Remove Programs; or, if the installation was aborted (clicking Cancel at the Self-Registration Error message), run force install.

Caution: To clear the message, you must edit Windows' registry. If you are unfamiliar with Windows' registry or its structure, it is highly recommended that you seek assistance before continuing with the following procedure.

First, it is recommended to create a backup of the registry:

  1. Click 'Start' and then 'Run'.

  2. In 'Open' box of Run window, type "REGEDT32" and then click 'OK'.

  3. In Registry Editor, select HKEY_LOCAL_MACHINE window and then click the SOFTWARE folder.

  4. From 'Registry' menu, select 'Save Key'.

  5. In Save Key window, select the appropriate drive and directory to store the back-up file by clicking the 'Save in' drop down arrow, entering a recognizable file name in the 'File name' box and then clicking the 'Save' button.

Steps to resolve the error:

  1. Open REGEDT32's Registry Editor.

  2. In HKEY_LOCAL_MACHINE window, double-click click the SOFTWARE folder.

  3. Click the Canon folder, click 'Security' menu and select 'Permissions'.

  4. In Permissions for Canon window, confirm 'Administrators' is highlighted in the 'Name' box, click 'Full Control' box and then click 'Advanced' button.

  5. In Access Control Settings for Canon window click 'Reset permissions on all child objects and enable propagation of inheritable permissions' box. A message box will appear.

  6. In Security window, click 'Yes' to continue and then click 'OK' at Permissions for Canon to close the open window.

  7. If MultiPASS Suite was partially installed (OK was clicked at the Self-Registration Error message), select 'Repair at the InstallShield Wizard' screen from Add/Remove Programs window. If MultiPASS Suite was not installed (Cancel was clicked at the Self-Registration Error window), run the force installation.

To run force installation on MultiPASS Suite 4.30:

  1. Click 'Start' and then 'Run'.

  2. Where 'X' represents your CD-ROM drive, type "X:\multipass\setup\frcinst.exe" and then click 'OK'. A Confirmation window will appear.

  3. Click 'Yes' to run this program and then click 'Yes' again to install the software.

  4. If the MultiPASS Setup splash screen is still open, proceed through installation normally.

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