When printing Does Not Start - MG4120

Article ID: ART111150 | Date published: 05/11/2015 | Date last updated: 08/17/2015
 

Description

When printing Does Not Start - MG4120

Solution

Printing does not start

Check 1: The printer may have been turned OFF. Go check the Auto Power OFF function


This printer has a function for automatically turning OFF.




The printer is turned OFF / Printing Does Not Start

Check 2: Make sure that the power plug is securely plugged in, then turn the printer on


While the POWER lamp is flashing, the machine is initializing. Wait until the POWER lamp stops flashing and remains lit.
REFERENCE
When printing large data such as a photo or graphics, it may take longer to start printing. While the POWER lamp is flashing blue, the computer is processing data and sending it to the machine. Wait until printing starts.



Check 3: Make sure that the machine is connected to your computer properly.


When the machine is connected to your computer with a USB cable, make sure that the USB cable is securely plugged in to the machine and the computer, then check the followings:

If you are using a relay device such as a USB hub, disconnect it, connect the machine directly to the computer, and try printing again. If printing starts normally, there is a problem with the relay device. Consult the reseller of the relay device for details.There could also be a problem with the USB cable. Replace the USB cable and try printing again.

When you use the machine over LAN, make sure that the machine is set up to be used over network correctly.



Check 4: Make sure that the front tray is open.



Check 5: If you are printing from the computer and there are any unnecessary print jobs, delete them.



Check 6: Make sure that your machine's name is selected in the Print dialog box.


The machine will not print properly if you are using a driver for a different printer.

Make sure that your machine's name is selected in the Print dialog box.
REFERENCE
To make the machine the one selected by default, select Set as Default Printer.



The machine will not print properly if you are using a driver for a different printer.

Make sure that your machine's name is selected in Printer in the Print dialog box.
REFERENCE
To make the machine the one selected by default, select Default Printer or Make Default.



Check 7: Configure the printer port appropriately.(Windows)


Make sure that the printer port is configured appropriately.

1. Log on as a user account with administrator privilege.

2. Select items from the Start menu as shown below.

In Windows 7, select Devices and Printers from the Start menu.In Windows Vista, select the Start menu > Control Panel > Hardware and Sound > Printers.In Windows XP, select the Start menu > Control Panel > Printers and Other Hardware > Printers and Faxes.

3. Open the properties of the printer driver for the machine.

In Windows 7, right-click the "Canon XXX Printer" icon (where "XXX" is your machine's name), then select Printer properties.In Windows Vista or Windows XP, right-click the "Canon XXX Printer" icon (where "XXX" is your machine's name), then select Properties.

4. Click the Ports tab to confirm the port settings.

Make sure that a port named "USBnnn" (where "n" is a number) with "Canon XXX Printer" appearing in the Printer column is selected for Print to the following port(s).
REFERENCE
When the machine is used over LAN, the port name of the machine is displayed as "CNBJNP_xxxxxxxxxx". "xxxxxxxxxx" is the character string generated from the MAC address or a character string specified by the user when setting up the machine.




If the setting is incorrect:

Reinstall the MP Drivers.

Printing does not start even though the machine is connected to the computer using a USB cable and the port named "USBnnn" is selected:

Launch Canon My Printer from the task tray, select Diagnose and Repair Printer. Follow the on-screen instructions to set the correct printer port, then select your machine's name.

If the problem is not resolved, reinstall the MP Drivers.

Printing does not start even though the port named "CNBJNP_xxxxxxxxxx" is selected when the machine is used over LAN:

Launch IJ Network Tool, and select "CNBJNP_xxxxxxxxxx" as you confirmed in step 4, then associate the port with the printer using Associate Port in the Settings menu.

If the problem is not resolved, reinstall the MP Drivers.



Check 8: Is the size of the print data extremely large?


Click Print Options on the Page Setup sheet on the printer driver. Then, set Prevention of Print Data Loss in the displayed dialog to On.



Check 9: Restart your computer if you are printing from the computer.



<Cause>

Is Auto Power Off function enabled?

This printer is automatically turned OFF when the printer is not used for a given length of time.

"240 minutes" is set by default.

You can change it to any of "Disable," "15 minutes," "30 minutes," "60 minutes," or "120 minutes." In order to change the setting, refer to the following information:


From the operation panel of the printer

1. Confirm that the printer is turned ON.


2. Select ECO settings on the HOME screen.


3. Select [Auto power off] using the button, and select [OFF] using the button; then, click OK button.

REFERENCE
The Auto power off setting is invalid under the following conditions.

  • When using the machine via a network.
  • When [ Writable from USB PC ] or [ Writable from LAN PC ] is selected for [ Read/write attribute ] under [ Device user settings ].


From the printer driver (Windows)

1. Confirm that the printer is turned ON.


2. Open "Properties" of the printer driver, then click [Auto Power] in the [Maintenance] tab.



3. Select [Disable] in [Auto Power Off], then click [OK].



From the printer driver (Macintosh)

According to the OS you are using, go to A or B:

Mac OS X v.10.6.x -> A

Mac OS X v.10.5.x -> B


  • A (For Mac OS X v.10.6.x)

1. Confirm that the printer is turned ON.


2. Open [Options & Supplies] in [Print & Fax], then click [Open Printer Utility] in the [Utility] tab.



3. Click [Auto Power] in [Power Settings].



4. Select [Disable] in [Auto Power Off], then click [OK].



  • B (For Mac OS X v.10.5.x)

1. Confirm that the printer is turned ON.


2. Click [Open Print Queue] in [Print & Fax], then open [Utility].



3. Click [Auto Power] in [Power Settings].



4. Select [Disable] in [Auto Power Off], then click [OK].




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