Printer Driver Currently in Use - PIXMA MX, MG, MP Series - Windows

Article ID: ART137753 | Date published: 05/13/2015 | Date last updated: 02/11/2020
 

Description

Resolve the "Printer driver currently in use" error in Windows for the PIXMA MX, MG and MP series printers.

Solution

Learn how to troubleshoot the "Printer driver currently in use" error message.


Cause

If you get an error message like the one below, when trying to uninstall printer drivers, you may have a print job or other applications running.

Printer driver is currently in use - error message


Action

Here's how to fix the error:

  1. Confirm that there are no print jobs in the queue.

  2. Hold down the Windows key and press the letter R, then type spool, in the Run box, and select OK.

  3. Windows Explorer should open to the Local Disk (C:)\Windows\System32\spool folder.

  4. Double-click the PRINTERS folder in the larger pane on the right side.

  5. If there is a file in this folder, highlight it. If there are multiple files, highlight them all. To do this, press and hold the CTRL+A buttons on the keyboard.

  6. Delete the files by holding down the CTRL+buttons on the keyboard.

  7. Close the Windows Explorer window.

  8. Hold down the Windows key and press the letter R, then type control printers in the Run box.

  9. From the Devices and Printers window, select the driver icon.

    Printer model selected from Printer menu
  10. At the top menu, select Print server properties.

  11. From the Print Server Properties window, select the Drivers tab.

  12. Under the Name column, find and select the printer driver you want to delete.

  13. Select the Remove... button.

  14. On the Remove Driver and Package window, select the Remove driver only radio button, then OK. When prompted to confirm the deletion of the printer driver, select Yes.


If two printer drivers are installed.

You may have two drivers installed, one titled Canon Inkjet XXX series and the other Canon XXX series Printer (where XXX is the model name).

If you have two drivers:

  1. Repeat steps 9 through 14 to delete the second driver.

  2. Once the printer driver is deleted, close the Print Server Properties and Devices and Printers windows.


If the "Unable to remove" message displays

If you get this message, follow the additional steps below.

Unable to remove XXX series printer error message
  1. Confirm that the icon is still selected (highlighted) in Devices and Printers, then select the Remove device button from the top menu.

  2. The Programs and Features window should still be open. If it's not, visit open the Programs and Features window for instructions.

  3. Now attempt to uninstall the MP Drivers from Programs and Features.


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