Fix damaged file that prevents launch of Canon software - My Image Garden or Quick Menu

Article ID: ART169028 | Date published: 11/16/2017 | Date last updated: 03/06/2019
 

Description

Learn how to correct an issue on a Windows computer when you receive the message that "A required file may have been deleted or damaged" when trying to start the applications My Image Garden or Quick Menu.

Solution


Damaged file message

The following message is displayed when trying to start some older versions of My Image Garden or Quick Menu:
Error message about corrupt file

Cause
This is caused by a corrupt file, and it can be repaired in two ways.

  • You can download and install the current version from the Canon website.
  • If you do not want to upgrade, you can delete the file causing the issue.

Upgrade My Image Garden to the current version

  • The easiest solution is to go to the the Drivers & Downloads page of the Canon website, enter your printer model name, and download the current version of the software.
  • Select the downloaded file and follow the prompts to install the new application.

Delete PersonSettings.xml

The alternative solution is to delete PersonSettings.xml.
  1. Select Start -> Computer.
  2. Enter the following URL in the address bar: C:\Users\%UserName%\AppData\Roaming\Canon\My Image Garden\AddOn\Person
  3. Select PersonSettings.xml and press Delete.
  4. The next time you start My Image Garden or Quick Menu, the PersonSettings.xml file gets recreated without the corruption.

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