The Printer Is Not Recognized Automatically (When Installing the Printer Driver)

Article ID: ART171093 | Date published: 07/24/2018 | Date last updated: 05/02/2019
 

Description

The Printer Is Not Recognized Automatically (When Installing the Printer Driver)

Solution

<Cause 1>
The printer is not turned ON.
<Solution>
Turn the printer ON.

<Cause 2>
The USB cable is not connected properly.
<Solution>
Connect the printer to a computer with a USB cable. Connect the flat connector of the USB cable to the computer, and connect the square connector to the printer.
NOTE
  • If your printer does not come with a USB cable, you will need to provide your own cable separately.
  • Make sure that the USB cable you use has the following mark.
  • If a Plug and Play automatic setup screen like the one shown below is displayed when you connect the USB cable, click [Close] or [Cancel] to close it.

<Cause 3>
The USB cable was already connected and the printer was turned ON before the printer driver was installed.
<Solution>
Perform the following procedure.

1. Turn OFF the printer.
The printer may not be recognized if you install the printer driver with the printer turned ON. Always turn OFF the power before installing.

2. When the following screen appears, connect the computer and the printer with a USB cable, and turn ON the printer.

<Cause 4>
The USB class driver is installed.
<Solution>
Uninstall the USB class driver using the following procedure.

Delete the USB class driver when it is not possible to install the printer driver correctly when using a USB connection. Note that even if you delete the USB class driver, it will be installed again automatically when you connect the printer and your computer with a USB cable.

1. Connect the printer and your computer with a USB cable, and turn ON the printer.

2. Log on to the computer with an administrator account.

3. Display [Device Manager].

4. Double-click [Universal Serial Bus controllers].

5. Right-click [USB Printing Support], and click [Uninstall].

IMPORTANT
Be careful to delete [USB Printing Support] only, and never delete any other devices or device drivers
  • Windows may not operate properly if you delete other devices or device drivers.

NOTE
If [USB Printing Support] is not displayed
  • [USB Printing Support] is not displayed if the USB class driver is not installed properly. In this case, close [Device Manager] without doing anything further.

6. Click [OK].

7. Close [Device Manager].

8. Unplug the USB cable, and restart your computer.


SIMS Doc Id

8203942100

Rate this Article
Was this article helpful?
Yes, This document is helpful
No, This document needs a clearer explanation
 
Please provide your comments