Support Code 1470 Appears - G620

Article ID: ART179704 | Date published: 04/27/2021 | Date last updated: 04/27/2021
 

Description

A print head isn't properly installed.

Solution

1470

Cause

Print head is not installed properly.

 

What to Do

Open the scanning unit / cover, then firmly push the print head locking cover (A).

Next, push the joint buttons (B) firmly to the end.

Push the print head locking cover (A), then the joint buttons (B)

Close the scanning unit / cover.

 Remove the orange label and the protective tape of the print head to install it.

Remove the orange label and the protective tape of the print head to install it

If your product issue was not resolved after following the steps above, or if you require additional help, please create or log in to your Canon Account to see your technical support options.

Or if you still need help, visit our Canon Community by clicking the button below to get answers:

Link to Canon Community Forum








____________________________________________________________________________________________


Rate this Article
Was this article helpful?
Yes, This document is helpful
No, This document needs a clearer explanation
 
Please provide your comments