macOS imagePROGRAF Print Plug-in Compatibility
Article ID: FAQ100647 | Date published: 01/24/2022 | Date last updated: 01/25/2022
 

Answer

The latest version of the imagePROGRAF Print Plug-in (version 6.03) is compatible with Photoshop versions CC 2019 - C2022 and DPP (version 4.8 or later).

Only the following printers are supported with v6.03:
iPF6400
iPF6400S
iPF6450
iPF8400
iPF8400S
iPF9400
iPF9400S

NOTE: If you are using a newer Mac that has the M1 chipset, you will need to ensure that Rosette 2 is installed for this plug-in to function properly.

NOTE: If you have one of the GP, PRO, TA, TM, TX, or TZ series printers, please use the Professional Print & Layout application/plug-in for Photoshop.