macOS Professional Print & Layout Compatibility
Article ID: FAQ100648 | Date published: 01/25/2022 | Date last updated: 03/15/2022
 

Answer

The latest version of macOS Professional Print & Layout (version 1.3.0) is compatible with Photoshop versions CC 2020 - 2022, Photoshop Elements 15-2022, Photoshop Lightroom Classic 9-11 and supports macOS 10.11.6 (64-bit) through macOS 12 (Monterey)

Only the GP/PRO series printers are supported with v1.3.0.

To install PPL (Professional Print & Layout), select [Plug-In Install] from [Application] -> [Canon Utilities] -> [Professional Print & Layout], then install the plug-in of PPL in the following folders:

- Adobe Photoshop 2022
   Installation: /Applications/Adobe Photoshop 2022/Plug-ins

- Adobe Photoshop Elements 2022
    Installation: /Applications/Adobe Photoshop Elements 2022/Plug-ins

- Adobe Photoshop Lightroom Classic 11.x
    Print Studio Pro plug-in will be automatically installed at installation of Print Studio Pro

NOTE: If you are using a newer Mac that has the M1 chipset, you will need to ensure that Rosetta 2 is installed for this plug-in to function properly.